This is a real mystery that I've tried to solve for about 6 weeks.

I've used the Siriusxm App for over a year. It's worked fine until about 6 weeks ago. Now, I try to launch the app but it never totally*connects. I can see the last show I watched in the background but the Siriusxm symbol is pulsating in the foreground. After a short period a popup*says "Sorry there was a problem please retry".

I can sign-in online on my PC. I can stream through satellite in my car. If I'm signed in on my PC ... and try to launch*the app ... a notice that I'm logged in somewhere else pops up. I need to click "continue on this device" on the PC. Yet I'm not signed in on the android app.*

BUT I usually try to launch*the app when I'm not signed in anywhere else. The android app still won't fully launch.*

I've cleared the cache on the android. I've cleared the data. I've also*uninstalled and reinstalled the app many times.*

The only clue I have is, now that XM is temporarily free, once I reinstall the android app it connects immediately once launched.

I can then sign-in with my user ID and password. The credentials are accepted and everything is fine. But if I close the app and try to re-launch the same old issue arises!

Hopefully, this an easy issue to resolve.*But ...