Results 1 to 8 of 8

Thread: Sirius reception issues on 91 Camaro with T-Tops

  1. #1
    RBC is offline
    Junior Member
    RBC's Avatar
    Joined: Sep 2008 Location: Commerce, Michigan Posts: 3

    Unhappy Sirius reception issues on 91 Camaro with T-Tops

    Hi, I have a Stiletto 2 that I installed both on my 91 Camaro and my 04 Grand Prix. Each car has its own car kit (cradle, antenna, power cord, etc.). For some ungodly reason, I can't seem to get good reception when driving the Camaro. When I drive the Grand Prix, the reception is awesome. Only breaks up once when I go under a lengthy underpass. The Camaro, however, breaks up every 10-20 seconds, sometimes losing signal for minutes (up to 5 mins.). I have changed antennas and antenna types and nothing seems to work. I was sure it had something to do with the fact that my car has very little metal for the antenna because of the T-tops, so I switched to an antenna with adhesive (instead of magnets) and attached it to my hatch window - no better; I tried the Nissan antenna (goes in the windshield) - couldn't make it work very well because of the plug. I tried switching cradles, thinking that was the issue - no luck. I am now thinking it could be the Stiletto 2, but that doesn't make sense, as it works fine in the Grand Prix. Does anyone have any ideas?? Would truly appreciate some insight.

  2. #2
    SteveSirius is offline
    Enthusiast
    SteveSirius's Avatar
    Joined: Jul 2008 Posts: 136
    Are you the same person as "Davebuck" who posted for the first time a few days ago with complaints. You may not be, but the coincidence of this being your first posting - with a complaint - is noticable. Coincidence, perhaps.

  3. #3
    RBC is offline
    Junior Member
    RBC's Avatar
    Joined: Sep 2008 Location: Commerce, Michigan Posts: 3
    Sorry, this is not "Davebuck".

  4. #4
    Demian is offline
    Mentor
    Demian's Avatar
    Joined: Oct 2008 Posts: 2,320
    Try calling Sirius and having them resend the signal to your stilletto. Do you drive in different areas with your other car? As long a there is a clear view of the southernish sky or you are around a terrestrial repeater, you shouldn't have a problem. Are you using the FM transmiter or are you hard wired to your car radio?

  5. #5
    sydneysky84 is offline
    Junior Member
    sydneysky84's Avatar
    Joined: Oct 2008 Posts: 7
    Quote Originally Posted by SteveSirius View Post
    Are you the same person as "Davebuck" who posted for the first time a few days ago with complaints. You may not be, but the coincidence of this being your first posting - with a complaint - is noticable. Coincidence, perhaps.
    lol

  6. #6
    mypearl is offline
    Member
    mypearl's Avatar
    Joined: Mar 2009 Posts: 62

    Thumbs up

    I own the same/similar car that you do. TPIS are also good local friends of mine and helped me fix this problem. First off our doors, trunk lid and t-tops are galvinized metal. Half metal and half fiberglass is the best way I can descripe it. That being said you have to make a ground plane for the antenna to work. Not having a ground plane present is making your signal go belly up.

    I'll explain when I'm not on iPhone but for now try your hood. I think that's actaully metal. Make sure you put it in 4 inces to make a ground plane.

  7. #7
    dukie is offline
    Junior Member
    dukie's Avatar
    Joined: Dec 2009 Posts: 1
    I have a 88 camaro convertable and set up my system as well.
    many have had problems like you and put the antenna on the hood as well.
    I put mine on the dash and have not had a problem
    Just my two.

  8. #8
    RBC is offline
    Junior Member
    RBC's Avatar
    Joined: Sep 2008 Location: Commerce, Michigan Posts: 3
    After the car being in storage for the winter and the body shop for nearly 5 months I now have it back. The antenna is on the hood, and now it's hit or miss. Some days I have great reception, while other days I have a constant "in" and "out": the radio will play for 3-6 seconds, then go into "acquiring signal" mode and not play for 3-6 seconds - a true nightmare.

    I am next going to try the dash as was suggested.

    Thanks to all for your input and suggestions.

  9. Ad Fairy Senior Member

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •