Results 1 to 6 of 6

Thread: Stiletto2 Device recovery won't load

  1. #1
    mikel is offline
    Junior Member
    mikel's Avatar
    Joined: Nov 2014 Posts: 1

    Stiletto2 Device recovery won't load

    I have a stiletto2 and it has frozen. I found the original disk (and the sirius website) and tried loading the device recovery software. I have tried it on two computer (one windows 8 and one windows 7). On both i get an error message (DPinst Result: -2147483648). Any ideas on how I can restore it?

  2. #2
    Michael McKeown is offline
    Junior Member
    Michael McKeown's Avatar
    Joined: Nov 2014 Posts: 3
    I think we're screwed. I'm having the same problem. I tried 2 different computers. Went into incompatible mode back to windows xp, vista, 7, and 8. Tried Chrome and Explorer. It either needs to be fixed on the Sirius site or they no longer support it. Unfortunately I think the latter is the case, no support. I'm going to try to contact them to get confirmation.

  3. #3
    Michael McKeown is offline
    Junior Member
    Michael McKeown's Avatar
    Joined: Nov 2014 Posts: 3
    I will post back if I figure anything out. I hope you will do the same.

  4. #4
    John Hogan is offline
    Junior Member
    John Hogan's Avatar
    Joined: Jun 2015 Posts: 1
    did you find out anything about this for I am having the same issue.

  5. #5
    97Formula is offline
    Junior Member
    97Formula's Avatar
    Joined: Jul 2016 Posts: 1
    The recovery software only works on XP, although I think it may also work on 7 if it is 32-bit (most computers today are 64-bit and the recovery will not work).

    To make things worse, even if you gain access to an older XP computer, it still won't work because it has to connect to the internet (which will fail because the servers that store the recovery firmware/ZAP are shut down). SL100 users can use the original CD to recover, but the SL2 users are pretty much stuck.

    I'm bummed about this because I just got a SL2 to replace my broken SL100, and the firmware was never updated on the SL2 I got. Does anyone here know where I can find a manual download of the latest SL2 firmware?

  6. #6
    lronglien is offline
    Junior Member
    lronglien's Avatar
    Joined: Jun 2016 Posts: 3
    TSS-Radio in Chicago will reload the software for $20. They are professional and you'll have your unit back right away. Great guys there!

  7. Ad Fairy Senior Member

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •