Results 1 to 4 of 4

Thread: subscription lost every time I turn off the ignition

  1. #1
    DCSunDevil is offline
    Junior Member
    DCSunDevil's Avatar
    Joined: Jun 2014 Posts: 1

    Unhappy subscription lost every time I turn off the ignition

    Has anyone ever had this problem? I lost my wallet and had to replace all the credit cards. I didn't update my CC info with Sirius and so after a big past due payment, my subscrption was cancelled. I resubscribed and everything was working fine except about a week later I noticed that my service in my car (an aftermarket Alpine) was lost. I would call and then they bwould refresh the signal and it would be fine until the next time I turned the car off. Here's the kicker- I get one of two messages when I try to pcik up any channel other than the adverstisement channel- I get "channel unsubscirbed" when I hit the presets. But they scrolling across the screen the rest of the time it says "subscription updated, press any key to continue."

    I've clled may be 10-15 times to have the signal refreshed and done it online as many times as well. The help overseas was of limited use besides refreshing the signal. I tried going on their Facebook page and and that help was better, and fianlly heard back from a guy but they said they would e-mail me information and never did.

    Marty in Md.

  2. #2
    Mplulse3g is offline
    Junior Member
    Mplulse3g's Avatar
    Joined: Aug 2016 Posts: 2
    I am having the same problem, except for me I just happened to get in my car one day and I was "unsubscribed" (no issues with payment). I can do the refresh signal, and everything is great until I turn off my car. I know this is a very old post - but was there ever any resolution? I have a alpine cde-sxm145bt radio.

  3. #3
    paulyjsob is offline
    Junior Member
    paulyjsob's Avatar
    Joined: Oct 2017 Posts: 2
    Same thing is happening with my Acura mdx.. Any solution?

  4. #4
    ksue is offline
    Junior Member
    ksue's Avatar
    Joined: Dec 2017 Posts: 1
    I thought I was the only one! Sirius customer service is of no help whatsoever. 2016 subaru and subscription worked fine for months until one day I was unsubscribed (no payment issues). Signal refreshed, but then I was again unsubscribed every time I turned off the car. Dealer said the radio was fine. Sirius customer disservice took no responsibility, lied to me about submitting a trouble ticket, and won't do anything to help. So, I will never be a customer of theirs again.

  5. Ad Fairy Senior Member

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •