Hey all,
Here's a problem I've been having with the SL2, even before the whole bug thing a few weeks ago. Everyone on these boards was so helpful last time, I wanted to see if anyone else was having a similar problem with their batteries.

The original battery that came with my SL2 started to bulge, like it was going to explode or something (I think it was getting too hot, since I leave the radio on a lot to record Howard). So, after finding out that you can't get a replacement battery from Sirius (of course), I went to Amazon and found a replacement battery for around $20.

That battery worked for a little while, but then the radio had another one of it's "glitches" and I had to do the whole "Reset and Erase" deal. Afterwards is when I noticed that the battery wasn't charging at all. I tried charging it from the car dock, the USB, the wall plug - nothing worked (by the way - if the SL2 is plugged directly into a power source, it will work without a battery in it). I figured that the battery connection inside the SL2 was broken or something, but definitely wasn't going to call Sirius for help (they'd probably try to convince me that the SL2 doesn't run on a battery!).

I ordered another battery just in case (since it was only $20) and sure enough, that one wouldn't charge either. Then, last weekend, my buddy came over with his SL2 (which actually works!) and we put both of my batteries into his radio. Wouldn't you know? The batteries wouldn't charge in his radio either! Unfortunately, he didn't have his working battery with him, but it really seems that the two batteries I got were DOA.

Still don't know what to do. Has anyone else had this problem? Is there some place else to get "working" SL2 batteries? I can't return the ones I have, too much time has passed. Thanks for any suggestions.