Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: Sirius Stiletto 2 Bug. Activation and Recording Issue since July 11, 2012

  1. #21
    beercoaster is offline
    Junior Member
    beercoaster's Avatar
    Joined: Jul 2012 Posts: 2
    Looks like my SL2 is fully operational!
    Check your radios guys everything's working now on my end.

  2. #22
    Pericles is offline
    Junior Member
    Pericles's Avatar
    Joined: Jul 2012 Location: Maryland Posts: 23
    Quote Originally Posted by MelRock10 View Post
    Turned on my SL2, set it to Channel 0 and it did the subscription update after about a minute, and it seems to be working fine now. I can access the Record function and Heard On Sirius.

    I still stand by my previous post that people need to call and demand a credit for the past 6 six days of interrupted service. That would get the point across that subscribers are paying attention and will not just stand by if they don't get what they pay for. I also hope this wasn't a ploy by Sirius to get a sense of peoples reaction if they were to separate channel programming from the recording functions. It's possible in the future they may try something like that to boost revenues. We all need to be on alert.

    Quote Originally Posted by beercoaster View Post
    Looks like my SL2 is fully operational!
    Check your radios guys everything's working now on my end.
    Ahhhhhhh. I can't wait to get home!

  3. #23
    hackintosh2000 is offline
    Junior Member
    hackintosh2000's Avatar
    Joined: Jul 2012 Posts: 9
    Quote Originally Posted by beercoaster View Post
    Looks like my SL2 is fully operational!
    Check your radios guys everything's working now on my end.
    My Stiletto 2 is back baby!!! I had to turn it off and take the battery out.

    Sirius still sucks though. They should have gotten information out sooner and been straight up. I bet if I called the customer service center right now the CS reps still wouldn't know about the problem. They are atrocious.

  4. #24
    MelRock10 is offline
    Junior Member
    MelRock10's Avatar
    Joined: Jul 2012 Location: Sacramento Posts: 8
    I have to agree. When I first got Sirius in 2008 I had some questions about my Starmate radio (the original one - anyone remember those?). I tried calling Sirius hoping to talk to someone who liked the radio, liked the service, was experienced with the equipment and instead got a guy from India who probably didn't even know what a satellite is. They're not very knowledgable about things that are happening with their own service and the communciation is horrible. If they had just put something on their website about the issue, their phone lines probably wouldn't be a half hour deep and I wouldn't be so insistant on getting a credit on my account - equipment / service failures happens; that's life. How they handle it is the important thing and they just failed miserably.

    Pass the word along that everyone who had issues with their radios this past week should call customer service and demand a credit for the past 5-6 days. Remember - you were paying for a service that you did not get! If enough people hold them accountable, maybe we'll see less problems in the future.
    Quote Originally Posted by hackintosh2000 View Post
    My Stiletto 2 is back baby!!! I had to turn it off and take the battery out.

    Sirius still sucks though. They should have gotten information out sooner and been straight up. I bet if I called the customer service center right now the CS reps still wouldn't know about the problem. They are atrocious.

  5. #25
    MelRock10 is offline
    Junior Member
    MelRock10's Avatar
    Joined: Jul 2012 Location: Sacramento Posts: 8
    Quote Originally Posted by Pericles View Post
    Ahhhhhhh. I can't wait to get home!
    Let us know how it goes. Also, let us know if you're able to get the credit to your account and if they give you any problems. Good luck!

  6. #26
    SiriusBuzz is online now
    Head Honcho
    SiriusBuzz's Avatar
    Joined: May 2007 Posts: 2,458
    I'm glad things are back up and working for you all. I came back to gather information for a front page article but, it looks like everything is magically resolved?

    Do owners still have to manually reset everything or has SiriusXM pushed out an update that fixes everything without SL2 owners having to do anything?
    Charles LaRocca
    SiriusBuzz Founder

  7. #27
    Jwenzel is offline
    Junior Member
    Jwenzel's Avatar
    Joined: Jul 2012 Posts: 5
    Was able to activate my SL2 - all Sirius channels. HOWEVER, still NO Best of XM channels. Will call Customer Care to see if that does anything.

  8. #28
    MelRock10 is offline
    Junior Member
    MelRock10's Avatar
    Joined: Jul 2012 Location: Sacramento Posts: 8

    Smile

    Quote Originally Posted by SiriusBuzz View Post
    I'm glad things are back up and working for you all. I came back to gather information for a front page article but, it looks like everything is magically resolved?

    Do owners still have to manually reset everything or has SiriusXM pushed out an update that fixes everything without SL2 owners having to do anything?
    I can't speak for anybody else, but all I did was turn my SL2 on in my car, tuned to Channel 0. Got the "Subscription Updated" notice after about a minute and it was all working. Even my older recordings were still there. I don't think it was "magically" resolved by any stretch of the imagination, but it is finally working. Any insider information on exactly what the problem was would be cool. Maybe a front page article will get people aware of what happened and to be on the lookout in case it happens again. Just don't forget to mention to people about getting the credit on their account.

    Thanks for the great forum. Looks like there are bunches of people here that have the same interest in satellite radio that I do. Wish I had found this place years ago! Thanks again.

  9. #29
    Jwenzel is offline
    Junior Member
    Jwenzel's Avatar
    Joined: Jul 2012 Posts: 5
    THE ISSUE IS NOT RESOLVED FOR THOSE WITH THE BEST OF XM.

    Customer Care (for Best of XM) sent another activation signal - shocker! Of course, it didn't work. They're going to escalate it (her words) higher and they should contact me via phone within the next 24 hours - I won't be holding my breath. I did get a ticket number: 1768470. I was promised it should be fixed within 3-5 days and they will contact me within 24 hours.

    I'm tired of talking to different people about my account who are in Egypt, the Philippines, India, or the US. No wonder they can't speak with one voice. It's a crap shoot who you get. It's too bad they can't have one person dedicated to working my (or similar peoples issues e.g. SL2 with no Best of XM) all the way through to completion.

    I also told her I was tired of being transferred over to technical support and having the line go dead on me (i.e. being hung up on). She told me it wasn't her fault sometimes it happens to her, also. This is where I cut her off and told her, "Yes, it is your fault - before transferring me or anyone else you SHOULD have said here's the number for technical support just in case you get disconnected - then transfer me."

    It's like that never dawned on her - rather than just execute that advice she said she'd let her supervisor know. Unbelievable.

  10. #30
    WalterWhite is offline
    Junior Member
    WalterWhite's Avatar
    Joined: Jul 2012 Posts: 1
    My S2 is operational again but whenever I set up a recording, I get that "file can't play" message when I try to get to my recorded show (I can usually FFWD over that to get to my recording but now it doesn't work). It also shows no time elapsed for trying to record a 6 hour recording. I hope this all gets fixed so I can at least record Howard on the replays this weekend.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •