Results 1 to 10 of 17

Thread: Stiletto SL100 Not Booting Up

Hybrid View

  1. #1
    ealvin is offline
    Junior Member
    ealvin's Avatar
    Joined: Aug 2010 Posts: 6

    Stiletto SL100 Not Booting Up

    All of a sudden when I attempt to turn on my SL100 get to 5 dots and it doesn't move beyond this point. Any ideas?

    Thanks for your help.

  2. #2
    my name is matt is offline
    Enthusiast
    my name is matt's Avatar
    Joined: Apr 2009 Location: Chicago Posts: 123
    This could just be a software related issue and it's fairly easy to fix. Do you still have your USB cable? If so, I would take a look at this link, download the device recovery software, then follow the device recovery guide on that link and it should get you back up and running. It has happened to my stiletto twice and both times the device recovery worked. Here is the link:
    http://www.sirius.com/servlet/Satell...nt%2FFlexEmpty

  3. #3
    ealvin is offline
    Junior Member
    ealvin's Avatar
    Joined: Aug 2010 Posts: 6
    Matt, thanks for your response. I'm so excited by your optimism that this will solve my problem.

    I have two questions.

    1. The USB cable I found doesn't seem to fit with either the Stiletto or its cradle. It doesn't look like the one in the manual that has the standard USB plug on one end and the same kind of plug as the one the headphones use on the other end. My USB cable has the standard plug on one end and the other end is about 1/2 the width and about 3/4ths of the height as the other end. This cable was in a ziplock back with all my Sirius stuff and I think this is what came with it but I can't see a way that it connects. Any ideas what I can do if this isn't the right cable?

    2, I installed the software but it didn't bootup and it doesn't show up in my Programs file. Could this be because the device isn't connected and once it is, it will boot up automatically? Does that sound correct?

    Thanks again for your response.
    Last edited by ealvin; 08-17-2010 at 07:37 PM.

  4. #4
    my name is matt is offline
    Enthusiast
    my name is matt's Avatar
    Joined: Apr 2009 Location: Chicago Posts: 123
    The program is a hidden program on your computer and will launch when you plug your stiletto in with the error message displayed on it's screen.

    I'm not sure what USB cable you have in your possession, but the one you need to have looks like this: http://www.tss-radio.com/products/stiletto-usb-cable

  5. #5
    ealvin is offline
    Junior Member
    ealvin's Avatar
    Joined: Aug 2010 Posts: 6
    Matt, I finally found the "right" USB chord and began the process of restoring but I don't think it's working, I'm in my second extended (9 hours now, 3 hours the first time) and I continue to get the "Recovering Please Wait..." message on my Stiletto.

    Also, this Stiletto was my second one to "go bad." I can't exactly remember now what the problem was with the first one but from just playing around with in now it seems that it doesn't hold a channel long and reboots.

    I'm now in the process of attempting to "restore" that one but it's been restoring now for about an hour and hasn't advanced beyond the "Recovering Please Wait..." stage.

    I thought I read somewhere that this recovery process shouldn't take very long and now I've tried it on two different Stilettos and it seems to be taking a very long time, which may be problematic.

    Any ideas on where to go from here?

    Thanks again for your help.
    Last edited by ealvin; 08-20-2010 at 03:04 PM.

  6. #6
    my name is matt is offline
    Enthusiast
    my name is matt's Avatar
    Joined: Apr 2009 Location: Chicago Posts: 123
    Did you hold down the options and display button while powering the device on to put it into recover mode before you plugged it into the computer? Also, make sure you are connected to the internet during the entire recovery process.

    My next question is, are you using a windows computer with either windows 7 or vista 64 bit. If so, the program doesn't not support these platforms and you will have to use a different computer.

    Outside of these, I'm not sure what other options to give you other than you could send it in to our company and we will attempt to make the recovery ourselves. If you would like to do that, I can arrange it for you.

  7. Ad Fairy Senior Member

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •