Results 1 to 4 of 4

Thread: Stiletto 100 not charging in car dock

Hybrid View

  1. #1
    jvhooser is offline
    Junior Member
    jvhooser's Avatar
    Joined: Nov 2009 Posts: 2

    Unhappy Stiletto 100 not charging in car dock

    I have had this stiletto 100 for over a year and never had a problem. All of a sudden it has quit charging in the car dock. No changes to anything with the radio, or the vehicle wiring. Could the charging circuit of the radio, or the dock have gone bad? Is this repairable?

    Thanks

  2. #2
    my name is matt is offline
    Enthusiast
    my name is matt's Avatar
    Joined: Apr 2009 Location: Chicago Posts: 123
    Do you have any other equipment you can cross test this with like a home dock or another car dock. It could be the car dock itself that has gone bad but it may also be the unit. If you have any other equipment you can cross test this with i would go ahead and do so.

  3. #3
    jvhooser is offline
    Junior Member
    jvhooser's Avatar
    Joined: Nov 2009 Posts: 2
    I have checked it with the home dock as well. No charging. The batteries will charge in the home dock without using the radio, just in the battery slot. I guess it is the charging circuit in the radio. Is this something repairable?

  4. #4
    my name is matt is offline
    Enthusiast
    my name is matt's Avatar
    Joined: Apr 2009 Location: Chicago Posts: 123
    We use a repair guy who is very successful with most repairs, but I know he cannot do anything with stilettos. Their circuit boards were put together with precision machines and are very small. He cannot operate on them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •